Problems/Virtual PC

If you are new to OS Development, plan on spending some time here first before going into the other forums.

Moderator: Moderators

Problems/Virtual PC

Postby Insightsoft » Sat May 21, 2011 8:07 pm

Hi,

I'm facing a little problem...

On Bocsh, VMWare (Fusion and Player), Parallels, etc it works just fine... but in Virtual PC generates a 'bad parameters sent to the driver'...

Here is a little background:

-Loading ROOT
works fine in all (including Virtual PC)

-When I try to load FAT
works fine in all (excluding Virtual PC)

How can be possible?

I already have reviewed all values passed to BIOS function, and it is correct... There is no crossed boundary (on buffer)...

And, as I always, I must understand why this is happening... Is there any clue?

Thanks
_____________
Think it, build it, bit by bit...
Insightsoft
 
Posts: 63
Joined: Wed Jul 22, 2009 6:44 am

Re: Problems/Virtual PC

Postby roboman » Sun May 29, 2011 6:03 pm

Does it work on real hardware outside an emulator?

If it works in several emulators and on hardware, then you have found one of the bugs or places where emulation under Virtual PC isn't 100%
roboman
 
Posts: 12
Joined: Fri Nov 28, 2008 10:02 pm
Location: usa

Re: Problems/Virtual PC

Postby Insightsoft » Fri Jun 10, 2011 11:27 am

....ya... it is, definitely, a VPC bug!!!
_____________
Think it, build it, bit by bit...
Insightsoft
 
Posts: 63
Joined: Wed Jul 22, 2009 6:44 am

Re: Problems/Virtual PC

Postby Mike » Fri Jun 10, 2011 6:35 pm

Hello,

The probability of it being a bug is very slim. Its probable -- but in almost all cases represents a compatibility error with your software. Have you tried it on real hardware?
User avatar
Mike
Site Admin
 
Posts: 463
Joined: Sat Oct 20, 2007 7:58 pm

Re: Problems/Virtual PC

Postby Insightsoft » Sat Jun 11, 2011 1:19 pm

Yes, mike...
It works better than MS-DOS (heheheheh. Just kidding!)... but it works!
_____________
Think it, build it, bit by bit...
Insightsoft
 
Posts: 63
Joined: Wed Jul 22, 2009 6:44 am

Re: Problems/Virtual PC

Postby halofreak1990 » Sat Jun 11, 2011 2:15 pm

I too have problems with the floppy driver in VPC.

Though I suppose it is due to the error-checking my driver does, since on real hardware, it cannot return the head to sector 0 in one try. So I retry a couple of times to get the head to where I want it. Unfortunately, that makes it hang in Virtual PC. I don't know why, though, because any document on floppy drives advises you to retry any command at least once because of drive specifics and other irregularities that occur on real hardware.

But if your OS works on real hardware, and you have a spare machine like I do, why not test it on real hardware?
It'll save you a lot of headaches trying to figure out why it won't work in VPC or Bochs (IIRC, my floppy driver doesn't like Bochs either)
halofreak1990
 
Posts: 92
Joined: Thu May 27, 2010 8:54 pm
Location: Netherlands

Re: Problems/Virtual PC

Postby Insightsoft » Sun Jun 12, 2011 7:36 pm

Already tested on real environment. And works... That's why that I think its a Microsoft problem... or something specific to the VPC must be done... and I don't know what it is...
_____________
Think it, build it, bit by bit...
Insightsoft
 
Posts: 63
Joined: Wed Jul 22, 2009 6:44 am


Return to Beginning OS Development

Who is online

Users browsing this forum: No registered users and 1 guest

cron